Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

WhiteSource Advise for IntelliJ IDEA supports Java, Kotlin and Scala projects using Maven (pom.xml dependency files), and supports Java projects using Gradle (build.gradle dependency files).

NOTENOTES: Gradle  

  • Gradle Kotlin projects are not supported in WhiteSource Advise.

  • When using the the "apply from" script plugin in Gradle projects, remote script location is not supported.

Prerequisites

Ensure the following prerequisites are met:

  • A valid license for WhiteSource for Developers

  • A license key for WhiteSource Advise for IDE, available via one of the following options:

    • If you do not have direct access to the WhiteSource Application, obtain the license key from your WhiteSource Administrator.

    • If you have access to the WhiteSource Application, do as follows (NOTE: This option is only available when using version 20.11.1 or later of WhiteSource Advise):

      1. Go to the WhiteSource Application.

      2. Open the Profile page.

      3. In the WhiteSource Advise - IDE Integration section at the bottom, select your organization.

      4. Copy your personal license key to be used later in Activating WhiteSource Advise.

  • Java JDK 1.8 and up (see here for instructions) or OpenJDK 1.8 and up is installed

  • Depending on whether scanning Maven or Gradle applications, note the following guidelines:

    • Apache Maven application is installed and the Maven path and all environment variables are set up (see here for instructions).

    • Gradle application is installed and the Gradle path and all environment variables are set up. NOTE: Gradle version 4.8 or above must be installed.

  • IntelliJ IDEA is installed and you are familiar with its basic functionality

  • The plugin supports the following IntelliJ IDEA versions:

    • 2020.3

    • 2020.2

    • 2020.1

    • 2019.3

    • 2019.2

    • 2019.1

    • 2018.3

    • 2018.2

    • 2018.1

    • 2017.3

    • 2017.2

  • Limitation - Gradle support for the following IntelliJ IDEA versions are notsupported on macOS: 

    • 2019.1

    • 2018.3

    • 2018.2

    • 2018.1

    • 2017.3

    • 2017.2

...